Resultados 1 a 4 de 4

Tópico: Mod-Security

  1. #1
    Aspirante a Evangelist
    Data de Ingresso
    Nov 2010
    Localização
    São Paulo
    Posts
    386

    Mod-Security

    Bom dia a todos.

    Verifiquei em meu mod_security a seguinte informação:

    Audit log: Failed to lock global mutex: Permission denied

    Também verifiquei no site de suporte do cpanel problemas de incompatibilidade com o mod Ruid2 incluso na versão nova e atualizada do cpanel.
    Pergunto seria este o problema não usar o mod ruid2 para não conflitar com o mod_security?

    agradeço mais uma vez se puderem ajudar.
    Carlos Nunes
    Analista de sistemas
    Desenvolvimento de Soluções para web.
    Criarnaweb E-Solutions
    www.criarnaweb.com.br
    https://br.linkedin.com/in/nunescarlos

  2. #2
    Guru Junior
    Data de Ingresso
    Oct 2011
    Posts
    181
    Existem varios topicos no forum do cPanel referente a este problema, não sei se já foi feito um patch para correção ou não mais uma das soluções que parecem estar utilizando para contornar o flood do mutex é:

    SecAuditLogModeDir 0770
    SecAuditLogModeFile 0640
    Outra seria você aplicar um umask 0007 no diretorio antes de iniciar o apache.

    ADD:
    O problema ocorre pelo apache rodar cada sub-processo com uid's diferentes impossibilitando um sub-processo de escrever ou modificar qlq no local que foi previamente iniciado por outra uid.
    Última edição por prixone; 11-04-2012 às 22:23.

  3. #3
    {topmember}
    Data de Ingresso
    Nov 2010
    Localização
    Rio de Janeiro
    Posts
    596
    Já que estamos falando de apache e aproveitando o tópico alguém esta usando o mod_ruid2 ?

    The mod_ruid2 Module

  4. #4
    Aspirante a Evangelist
    Data de Ingresso
    Nov 2010
    Localização
    São Paulo
    Posts
    386
    Muito obrigado a todos pela ajuda.
    No meu vps, tive que voltar a versão stable do cpanel para que os logs do mod_security fiquem ok, alem de desabilitar o mod_ruid2 que estava em teste na versão release.
    Agora esta redondinho o meu vps.
    Efetuei testes em outro servidor mas com o cpanel em release e desabilitando o mudulo _ruid2 e funcionou sem problemas o mod_security meu e apache.
    Não sei se é isto mas achei muito esquisito esta situação e no forum cpanel internacional vi registros de incompatibilidade.
    Carlos Nunes
    Analista de sistemas
    Desenvolvimento de Soluções para web.
    Criarnaweb E-Solutions
    www.criarnaweb.com.br
    https://br.linkedin.com/in/nunescarlos

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •