Resultados 1 a 8 de 8
  1. #1
    Guru Junior
    Data de Ingresso
    Mar 2011
    Posts
    217

    Conexão com FTP reiniciada a cada x segundos

    Olá

    Estou com o seguinte problema, ao enviar algum arquivo via ftp a conexão é reiniciada a cada intervalo que em média fica entre 30 e 50 segundos, o cliente de ftp informa somente que a conexão foi abortada pelo servidor e então reconecta e continua o upload normalmente (nem sempre o upload continua onde parou, as vezes reinicia mais isso é outra questão) o servidor usa cpanel e pureftpd, já troquei para proftpd e o mesmo problema ocorre, já desativei o firewall (CSF) e o mesmo problema ocorre, até já reiniciei o servidor, em var/log/messages não encontrei nada nos logs, quando existe problema de conexão lenta entre cliente e servidor geralmente aparece nos logs, os logs somente mostram o que já citei acima, que a conexão foi finalizada e o upload foi reiniciado ou iniciado novamente, verifiquei que o problema acontece em qualquer conta do servidor, até pensei que fosse problema de conectividade entre cliente (Brasil) e servidor (EUA) mais conectei de um servidor dos EUA e o mesmo problema acontece. Outros serviços como ouvir ou transmitir streaming para o servidor funcionam normalmente, se fosse quedas por problema de conectividade creio que teria o mesmo problema em todos os serviços, o servidor não está sobrecarregado nem no load nem no tráfego e não há relatos de problemas parecidos nos demais serviços, alguem teria uma luz do que poderia ser o problema?

  2. #2
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    Yuri, parece um mistério realmente.

    Quando você desativou o csf, certificou-se de que não haviam regras no iptables? (iptables -L)
    Faça o teste desativando o firewall no csf -x e então liste as regras com o iptables -L.

    Não execute o flush das regras (iptables -F) com o csf ativo, pois você será derrubado
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  3. #3
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    15,050
    Você experimentou download do e para o servidor com wget (protocolo HTTP)?

  4. #4
    Guru Junior
    Data de Ingresso
    Mar 2011
    Posts
    217
    Citação Postado originalmente por AlexandreWCB Ver Post
    Yuri, parece um mistério realmente.

    Quando você desativou o csf, certificou-se de que não haviam regras no iptables? (iptables -L)
    Faça o teste desativando o firewall no csf -x e então liste as regras com o iptables -L.

    Não execute o flush das regras (iptables -F) com o csf ativo, pois você será derrubado
    Olá

    CSF desativado, (iptables -F) e ftp reiniciado e infelizmente o mesmo problema continua.

  5. #5
    Guru Junior
    Data de Ingresso
    Mar 2011
    Posts
    217
    Citação Postado originalmente por 5ms Ver Post
    Você experimentou download do e para o servidor com wget (protocolo HTTP)?
    Funciona normal, testei com um arquivo de 1.7 GB, demorou uns 2 - 3 minutos sem qualquer problema.

  6. #6
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    Você disse que a conexão do servidor B para o servidor A também apresenta o problema, certo? Então podemos descartar falha na sua conexão.

    Você possui alguma ferramenta que verifica os processos e os mata por razão X, como o LFD faz? Se não me engano o prm fazia isso também.

    É um dedicado ou VPS?
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  7. #7
    Guru Junior
    Data de Ingresso
    Mar 2011
    Posts
    217
    Citação Postado originalmente por AlexandreWCB Ver Post
    Você disse que a conexão do servidor B para o servidor A também apresenta o problema, certo? Então podemos descartar falha na sua conexão.

    Você possui alguma ferramenta que verifica os processos e os mata por razão X, como o LFD faz? Se não me engano o prm fazia isso também.

    É um dedicado ou VPS?
    Bingo, foi isso mesmo, tinha uma ferramenta rodando e matando os processos do usuário, eu mesmo configurei isso no ano passado pois a conta estava dando uns picos e quase derrubando o servidor, valeu pela ajuda, nunca iria lembrar disso, já fazia tanto tempo, o problema com a conta já havia sido resolvido e eu esqueci de desfazer a configuração.

    Obrigado a todos....

  8. #8
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    Isto fica feliz em ser útil
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •