Resultados 1 a 2 de 2
  1. #1
    Novo Membro
    Data de Ingresso
    Dec 2012
    Posts
    1

    [Ajuda] mod_rewrite + .htaccess

    Bom dia pessoal,

    Adquiri recentemente um Smart Serve na IWeb, com um pouco de trabalho e muita pesquisa, fiz todas as configurações necessárias para meus sites, após realizar a migração de um site de teste, percebi que as URL's amigáveis não estão funcionando, sei que esse problema pode ocorrer com o mod_rewrite do apache ou no arquivo .htaccess, pesquisei bastante, inclusive aqui no fórum, mais não encontrei uma solução para o meu problema, alguém já passou por isso? Poderiam me ajudar?

    Detalhes:

    SO: Centos 6
    CPanel/WHM: 11.34.1

    Com o CPanel, o mod_rewrite já vem compilado junto com o apache, verifiquei isso com o comando:

    Código:
    httpd -l | grep mod_rewrite
    Retorno

    Código:
    mod_rewrite.c
    No arquivo /etc/httpd/conf/httpd.conf

    Código:
    ...
    
    RewriteEngine on
    
    ...
    
    <Directory "/">
    Options All
    AllowOverride All
    </Directory>
    
    ...
    Utilizo o Joomla 2.5 que dá suporte a URL amigáveis, quando desabilito a opção de "utilizar URL's amigáveis com o mod_rewrite", o site funciona normalmente.

    .htaccess (do Joomla)

    Código:
    ## Can be commented out if causes errors, see notes above.
    Options +FollowSymLinks
    
    ## Mod_rewrite in use.
    
    RewriteEngine On
    Agradeço a ajuda de todos!

  2. #2
    WHT-BR Top Member
    Data de Ingresso
    Nov 2010
    Localização
    Rio de Janeiro - RJ
    Posts
    2,289
    Você recompilou o apache com o mod_rewrite? Execute o EasyApache e não se esqueça de marcar esta opção.

Tags para este Tópico

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •