Resultados 1 a 7 de 7

Tópico: Erro PDO

  1. #1
    WHT-BR Top Member
    Data de Ingresso
    Nov 2010
    Localização
    Rio de Janeiro - RJ
    Posts
    2,291

    Erro PDO

    Tive problemas após executar o EasyApache e instalar o Wordpress 3.0.5. O arquivo error_log que ficava no public_html onde o wordpress estava instalado mostrava as seguintes linhas:

    Código:
    [10-Feb-2011 22:59:10] PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [10-Feb-2011 22:59:10] PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    Isso sempre aparecia neste arquivo na hora em que eu me logava no wordpress.

    Para resolver isso executei novamente o EasyApache e selecionei o profile padrão "PHP Encryption and Image Manipulation" e mandei recompilar, sem personalizar. E o Wordpress voltou a funciona após efetuar login nele.

    Mas... um fórum que tinha em phpBB parou de funcionar, então resolvi instalar o SMF e consegui importar, mas isso me deixou encucado e com as seguintes dúvidas:

    1) o que fez gerar esse erro do PDO?

    2) porque ao executar o EasyApache novamente com o profile "PHP Encryption and Image Manipulation" o fórum phpBB parou de funcionar?

    3) Esse profile que escolhi, "PHP Encryption and Image Manipulation", é realmente a melhor escolha para hospedagem de sites em geral?

    Conto com a ajuda de vocês.

  2. #2
    Quero ser Guru
    Data de Ingresso
    Feb 2011
    Localização
    Rio de Janeiro
    Posts
    48
    Citação Postado originalmente por tekobr Ver Post
    Tive problemas após executar o EasyApache e instalar o Wordpress 3.0.5. O arquivo error_log que ficava no public_html onde o wordpress estava instalado mostrava as seguintes linhas:

    Código:
    [10-Feb-2011 22:59:10] PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [10-Feb-2011 22:59:10] PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    Isso sempre aparecia neste arquivo na hora em que eu me logava no wordpress.

    Para resolver isso executei novamente o EasyApache e selecionei o profile padrão "PHP Encryption and Image Manipulation" e mandei recompilar, sem personalizar. E o Wordpress voltou a funciona após efetuar login nele.

    Mas... um fórum que tinha em phpBB parou de funcionar, então resolvi instalar o SMF e consegui importar, mas isso me deixou encucado e com as seguintes dúvidas:

    1) o que fez gerar esse erro do PDO?

    2) porque ao executar o EasyApache novamente com o profile "PHP Encryption and Image Manipulation" o fórum phpBB parou de funcionar?

    3) Esse profile que escolhi, "PHP Encryption and Image Manipulation", é realmente a melhor escolha para hospedagem de sites em geral?

    Conto com a ajuda de vocês.

    Parece que vc está tentando carregar o mesmo módulo 2 vezes, olha no arquivo php.ini quantas vezes ele está sendo carregado.

  3. #3
    Quero ser Guru
    Data de Ingresso
    Oct 2010
    Posts
    35
    Citação Postado originalmente por jesmarcelo Ver Post
    Parece que vc está tentando carregar o mesmo módulo 2 vezes, olha no arquivo php.ini quantas vezes ele está sendo carregado.
    já tive este problema com outro modulo e era isso mesmo, estava sendo carregado duas vezes.

  4. #4
    WHT-BR Top Member
    Data de Ingresso
    Nov 2010
    Localização
    Rio de Janeiro - RJ
    Posts
    2,291
    Obrigado pessoal,vou verificar o php.ini

    Mas as minhas dúvidas 2 e 3?

  5. #5
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    Não confie no profile pré-configurado.
    Personalize.

    Obviamente seu phpBB parou de funcionar por haverem libs faltando.

    Com o tempo, você vai pegando o básico que o pessoal mais usa e monta seu próprio profile.
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  6. #6
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    Em phpBB • 1.1. você pode ver as libs que precisam ser compiladas para o phpBB funcionar:

    zlib Compression support
    Remote FTP support
    XML support
    Imagemagick support
    GD support
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  7. #7
    WHT-BR Top Member
    Data de Ingresso
    Nov 2010
    Localização
    Rio de Janeiro - RJ
    Posts
    2,291
    Alexandre, tudo isso estava selecionado, além de não ser essencial para o phpBB funcionar (é opcional), mas de qualquer forma já estava instalado.

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •