Resultados 1 a 7 de 7
  1. #1
    Quero ser Guru
    Data de Ingresso
    Apr 2012
    Posts
    36

    Uso de RAID 1 por software ou hardware com problemas ao fazer backup cpanel

    Pessoal,

    estou experimentando o raid e só tive experiências frustrantes. Ao fazer, com Cpanel, transferência de contas, backup ou restore o sistema trava. Testei com software e hardware raid, o mesmo problema aconteceu.

    Escolhi o raid 1, 2 discos de 2TB, servidor quad core 8x2.5GHZ, 16G ram.

    Parece que o problema ocorre ao fazer a compactação e descompactação das contas, tentei utilizando apenas o gzip, depois o pigz (utilizando até 2 processadores também travou) e com prioridade de IO baixa. Testei diversas configurações e todas falharam.

    Na primeira tentativa eu estava usando raid 1 + lvm, então testei sem o lvm e também não tive sucesso. Depois testei deixando o /backup em um hd fora do raid, continuou dando problema.

    Então decidi contratar um placa raid LSI Megaraid "lsi megaraid sas 9260-4i", fiquei super confiante, besteira. Dessa vez quando travou durante a transferência pela primeira vez corrompeu o sistema de arquivos, tive que passar o fsck pra corrigir.

    Segue o log sysstat durante a transferência utilizando a placa raid, a transferência iniciou por volta das 7h am e o sistema travou as 9:30.

    Não pude postar aqui, excesso de caracteres, segue o arquivo....
    log-raid-crash.txt

    A única diferença deste sintoma no software raid é que o load average dispara loucamente, neste caso com hardware raid o load está tranquilo a 4.0... Há um pico de escrita até que não da conta e trava.

    Alguém já passou por isso? Tem ideia do que pode está acontecendo?

  2. #2
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    15,002
    A área de swap está fora do RAID?

  3. #3
    Quero ser Guru
    Data de Ingresso
    Apr 2012
    Posts
    36
    Citação Postado originalmente por 5ms Ver Post
    A área de swap está fora do RAID?
    swap dentro do raid... pensei nisso viu, mas não testei. o swap fora do raid ficaria apenas em um disco, certo?

    instalei o centos7 + cpanel e deu certo a transferência e backup. estou testando com o cloudlinux, mas agora acho que deu certo, o centos7 administrou melhor, o backup que durava umas 6h está finalizando em 4h agora.

  4. #4
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    15,002
    Se não estou enganado, o arquivo que você anexou mostra paginação intensa, impactanto o HD (mesmo 1 só) e CPU (no RAID por software). Talvez seja decorrente de uso de arquivos temporários, porque o tmpfs usa o mesmo mecanismo do swap.
    Última edição por 5ms; 19-09-2015 às 16:21.

  5. #5
    Quero ser Guru
    Data de Ingresso
    Apr 2012
    Posts
    36
    Por que teria uma paginação intensa fazendo backup? É muito estranho.

    Depois que instalei o Centos 7 não tive mais este problema com os backups e transferências. Mas continua tendo uma paginação maior do que o normal.

    Veja a configuração e o teste de leitura e escrita:

    Xeon® Processor 2x L5420 12M Cache, 2.50 GH, 4 núcleos - 16G RAM

    Model Family: Seagate Barracuda 7200.14 (AF)
    Device Model: ST2000DM001-1CH164

    Utilizando RAID 1

    # hdparm -tT /dev/md123
    Timing cached reads: 11860 MB in 2.00 seconds = 5937.29 MB/sec
    Timing buffered disk reads: 298 MB in 3.03 seconds = 98.31 MB/sec

    # dd if=/dev/zero of=/root/testfile bs=500M count=1 oflag=direct
    1+0 records in
    1+0 records out
    524288000 bytes (524 MB) copied, 7.14506 s, 73.4 MB/s

    Acha normal o nível de leitura/escrita? Estou testando com outros servidores para comparar e vou postar em um outro post:
    http://www.webhostingtalk.com.br/for...5840#post35840
    Última edição por diogo-andrade; 25-09-2015 às 12:19.

  6. #6
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    15,002
    Citação Postado originalmente por diogo-andrade Ver Post
    Por que teria uma paginação intensa fazendo backup? É muito estranho.
    Porque está usando arquivos temporários no processo e/ou está ocupando muita memória (você está zipando?). Essa "paginação" que eu observei é "uso do mecanismo de paginação", que pode ser usado para mover páginas RAM <-> HD mas também é usado para arquivos temporários TMPFS, o que eu *acho* mais provável no caso.

  7. #7
    Quero ser Guru
    Data de Ingresso
    Apr 2012
    Posts
    36
    Citação Postado originalmente por 5ms Ver Post
    Porque está usando arquivos temporários no processo e/ou está ocupando muita memória (você está zipando?). Essa "paginação" que eu observei é "uso do mecanismo de paginação", que pode ser usado para mover páginas RAM <-> HD mas também é usado para arquivos temporários TMPFS, o que eu *acho* mais provável no caso.
    Sim, o backup estava zipando. Era cerca de 180G dividido entre 80 contas. Trabalho que fazia perfeitamente em outro servidor com metade de ram, centos6, mas sem raid. Hoje com o centos7 e raid faz bem mais rápido o bakcup e sem erro. Mas com o centos6, com raid, sempre travava. Iniciava um grande uso de paginação e io, de repente o load average aumentava drasticamente até ficar sem resposta. Verifiquei o caso com o Cpanel, verificaram o servidor e não chegaram a nenhuma conclusão também, só pediram alguns testes de configurações diferentes. Fiz cerca de 4 ou 5 testes com configurações diferentes e nada resolveu : ( sofri um bocado. Passou, ufa! Mas é muito chato ficar algo misterioso.

Tags para este Tópico

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •