Para você que tem dúvidas nas configuraçãoes de segurança do seu servidor segue abaixo este pequeno script que quando executado via ssh nos reporta problemas de segurança e como corrir.

1- cd /usr/local/src
download script
tar -zxvf lynis-1.2.9.tar.gz
cd lynis-1.2.9
./lynis --check-update

2- Para rodar execute no seu ssh como root:

./lynis -c -Q

Verifique se seu servidor esta realmente bem configurado, caso reporte algum problema siga as informações de segurança reportadas e suas soluções por ela apresentadas.