Resultados 1 a 2 de 2
  1. #1
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    17,239

    [EN] Switches Cisco Catalyst vulneráveis a invasões da CIA

    Yevgeniy Sverdlik
    March 21, 2017



    More than 300 models of Cisco switches are vulnerable to an exploit included in the trove of alleged CIA hacking tools WikiLeaks published earlier this month.

    Cisco disclosed the vulnerability in an advisory issued Friday, listing primarily products from its Catalyst and Industrial Ethernet lines. The list does not include any Nexus data center switches.

    The vulnerability is in the way operating systems Cisco IOS and Cisco IOS XE process Cluster Management Protocol code. CMP is used to manage clusters of switches and uses the Telnet protocol for communication between switches within a cluster.

    According to Cisco, CMP-specific options are not restricted to internal, local communications between cluster members, and therein lies the vulnerability. A Telnet-enabled switch can be accessed over any Telnet connection.

    The second factor that makes the switches vulnerable is “incorrect processing of malformed CMP-specific Telnet options.”

    “An attacker could exploit this vulnerability by sending malformed CMP-specific Telnet options while establishing a Telnet session with an affected Cisco device configured to accept Telnet connections,” Cisco’s advisory reads. “An exploit could allow an attacker to execute arbitrary code and obtain full control of the device or cause a reload of the affected device.”

    There are currently no fixed releases of the software, Cisco said, recommending that users disable Telnet protocol for incoming connections to prevent the vulnerability from being exploited on their networks.

    Cisco discovered the vulnerability during analysis of documents in WikiLeaks’s so-called Vault 7 disclosures. There is no indication the vulnerability has been used by the CIA or someone outside the agency.

    WikiLeaks claims the release of Vault 7 is “the largest ever publication of confidential documents on the agency.” The first batch of documents it released, called “Year Zero,” contains 8,761 documents and files “from an isolated, high-security network situated inside the CIA’s Center for Cyber Intelligence in Langley, Virginia.”

    The organization says it received the “collection” from one of “former US government hackers and contractors” among whom it had been circulated in an unauthorized manner.


    http://www.datacenterknowledge.com/a...-by-wikileaks/

  2. #2
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    17,239

    Cisco IOS and IOS XE Software Cluster Management Protocol Remote Code Execution Vulne

    A vulnerability in the Cisco Cluster Management Protocol (CMP) processing code in Cisco IOS and Cisco IOS XE Software could allow an unauthenticated, remote attacker to cause a reload of an affected device or remotely execute code with elevated privileges.

    The Cluster Management Protocol utilizes Telnet internally as a signaling and command protocol between cluster members. The vulnerability is due to the combination of two factors:

    • The failure to restrict the use of CMP-specific Telnet options only to internal, local communications between cluster members and instead accept and process such options over any Telnet connection to an affected device, and
    • The incorrect processing of malformed CMP-specific Telnet options.


    An attacker could exploit this vulnerability by sending malformed CMP-specific Telnet options while establishing a Telnet session with an affected Cisco device configured to accept Telnet connections. An exploit could allow an attacker to execute arbitrary code and obtain full control of the device or cause a reload of the affected device.

    Cisco will release software updates that address this vulnerability. There are no workarounds that address this vulnerability.

    This advisory is available at the following link:
    https://tools.cisco.com/security/cen...a-20170317-cmp

    Vulnerable Products

    This vulnerability affects the following Cisco devices when running a vulnerable Cisco IOS software release and configured to accept incoming Telnet connections:

    ...

    https://tools.cisco.com/security/cen...a-20170317-cmp

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •