Resultados 1 a 4 de 4
  1. #1
    Web Hosting Evangelist
    Data de Ingresso
    Nov 2010
    Posts
    463

    Não recebe e nem envia emails

    Estou com um problema no meu serviço de email (cPanel) do nada deu problema agora.
    Não está enviando emails e apresenta este erro:
    Erro SMTP: [530] Relaying not allowed - local sender address
    E não recebe dizendo que não existe a conta de email
    Mas todas as contas de emails existem e acessa normalmente o webmail.
    Já reiniciei o serviço de email, fiz reparo nas permissões das contas de email e não resolveu.
    Alguém tem alguma ideia do que possa ser?

  2. #2
    Aspirante a Evangelist
    Data de Ingresso
    Nov 2010
    Localização
    São Paulo
    Posts
    398
    Verifique o limite de emails nas configs avançadas em seu exim se estiver usando relay mude pelo menos para 1000, depois em Mail Routing Settings mude para automatico e teste se não funcionar mude para local.
    Carlos Nunes
    Analista de sistemas
    Desenvolvimento de Soluções para web.
    Criarnaweb E-Solutions
    www.criarnaweb.com.br
    https://br.linkedin.com/in/nunescarlos

  3. #3
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Posts
    17,329
    @Seto_Ichitaka

    Provavelmente você já resolveu o problema. Caso contrário, nunca usei cPanel ou Exim mas parece estar ocorrendo um problema na autenticação, seja comunicação (permissão de socket), programa utilizado para verificar autorizações, ou no banco de dados. Para hospedagem, o normal é somente permitir envio para usuários autenticados e receber para contas cadastradas, ambos exigindo consulta à base de dados de usuários. No Postfix, uma falha nesse mecanismo é gravada nos logs e imagino que ocorra no Exim também. Eu utilizo Postfix+Dovecot+Postgres e a cada reboot é realizada uma espera até que os componentes anteriores estejam rodando ok: 1) Dovecot aguarda Postgres e 2) Postifx aguarda Dovecot, de forma que o Postfix não inicia até o mecanismo de autenticação (no caso, Dovecot+Postgres) estar funcionando. Sem o mecanismo, o Postfix rejeita as operações de envio e recebimento, mas não como usuário não existente e sim informando erro de operação do sistema se a configuração utiliza autorização.
    Última edição por 5ms; 15-07-2017 às 11:28.

  4. #4
    Web Hosting Evangelist
    Data de Ingresso
    Nov 2010
    Posts
    463
    Citação Postado originalmente por 5ms Ver Post
    @Seto_Ichitaka

    Provavelmente você já resolveu o problema. Caso contrário, nunca usei cPanel ou Exim mas parece estar ocorrendo um problema na autenticação, seja comunicação (permissão de socket), programa utilizado para verificar autorizações, ou no banco de dados. Para hospedagem, o normal é somente permitir envio para usuários autenticados e receber para contas cadastradas, ambos exigindo consulta à base de dados de usuários. No Postfix, uma falha nesse mecanismo é gravada nos logs e imagino que ocorra no Exim também. Eu utilizo Postfix+Dovecot+Postgres e a cada reboot é realizada uma espera até que os componentes anteriores estejam rodando ok: 1) Dovecot aguarda Postgres e 2) Postifx aguarda Dovecot, de forma que o Postfix não inicia até o mecanismo de autenticação (no caso, Dovecot+Postgres) estar funcionando. Sem o mecanismo, o Postfix rejeita as operações de envio e recebimento, mas não como usuário não existente e sim informando erro de operação do sistema se a configuração utiliza autorização.
    O problema realmente era mais ou menos isso mesmo, mas por culpa de uma atualização bugada do assp delux, aí lançaram outra e eu atualizei.
    O problema foi descobrir isso, o dia e a noite inteiro até perceber...rs

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •