Resultados 1 a 5 de 5

Tópico: iotop

  1. #1

    iotop

    Ola pessoal estou tentando instalar no meu centos o iotop, para monitorar a leitura e gravação de disco,


    na verdade ja instalei ele. mas quando vou executar ele da a seguinte

    Could not run iotop as some of the requirements are not met:
    - Python >= 2.5 or Python 2.4 with the ctypes module


    ma o Python esta instalado segue

    root@srv01 [/]# python -V
    Python 2.5.2

    e na versão solicitada, alguem sabe o que pode ser ?

  2. #2
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    A linha do erro está completa?

    Pelo que vi no Google, deveria ser uma das abaixo:

    Código:
    - Python >= 2.5 or Python 2.4 with the ctypes module: Found
    - Python >= 2.5 or Python 2.4 with the ctypes module: Not Found
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  3. #3
    WHT-BR Top Member
    Data de Ingresso
    Dec 2010
    Localização
    /sc/rionegrinho
    Posts
    1,036
    A propósito, se o ctypes não estiver instalado, instale-o

    yum/apt-get install python-ctypes
    Alexandre Silva Hostert

    Veezon
    Gerenciamento de Servidores


    http://veezon.com.br
    http://br.linkedin.com/in/alexandreveezon

  4. #4
    Citação Postado originalmente por AlexandreWCB Ver Post
    A linha do erro está completa?

    Pelo que vi no Google, deveria ser uma das abaixo:

    Código:
    - Python >= 2.5 or Python 2.4 with the ctypes module: Found
    - Python >= 2.5 or Python 2.4 with the ctypes module: Not Found
    sim a linha esta completa

  5. #5
    Citação Postado originalmente por AlexandreWCB Ver Post
    A propósito, se o ctypes não estiver instalado, instale-o

    yum/apt-get install python-ctypes
    efetuei a instalação mas agora estou com o seguinte erro


    Código:
    root@srv01 [/]# iotop
    Traceback (most recent call last):
      File "/usr/local/bin/iotop", line 4, in <module>
        import pkg_resources
      File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 2562, in <module>
      File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 626, in require
      File "build/bdist.linux-x86_64/egg/pkg_resources.py", line 524, in resolve
    pkg_resources.DistributionNotFound: iotop==0.3.1
    root@srv01 [/]#

Permissões de Postagem

  • Você não pode iniciar novos tópicos
  • Você não pode enviar respostas
  • Você não pode enviar anexos
  • Você não pode editar suas mensagens
  •